Our services have recovered and are now operating at normal service levels.
Posted Jun 03, 2025 - 23:56 UTC
Update
The responsible team continues to closely monitor the system. Response times can still be elevated for some users.
Posted Jun 03, 2025 - 22:11 UTC
Update
We are continuing to monitor any further issues
Posted Jun 03, 2025 - 21:48 UTC
Update
We are still monitoring API responses and payment notifications
Posted Jun 03, 2025 - 21:18 UTC
Monitoring
API responses are back to normal, but some requests are being throttled.
Payment notifications are back to normal.
Posted Jun 03, 2025 - 20:43 UTC
Identified
API responses are back to normal.
Engineers are now working to recover Payment notifications.
Posted Jun 03, 2025 - 20:20 UTC
Investigating
We identified the root cause, recovering and will recover all services soon.
Posted Jun 03, 2025 - 20:20 UTC
Update
Our engineers are actively working to recover the system. The root cause has been identified, and remediation efforts are being expedited to restore services as quickly as possible.
Posted Jun 03, 2025 - 20:15 UTC
Identified
Instability in Local Latam API, causing partial downtime in Local Latam API.