Major payment service outage

Incident Report for EBANX

Resolved

Service Level back to normal.
Posted Mar 25, 2025 - 21:32 UTC

Monitoring

Service Level back to normal.
Posted Mar 25, 2025 - 21:11 UTC

Update

We are facing some issues with our payment API. We are investigating the root cause and it can affect several payment types and countries in LOCAL LATAM environment.
Posted Mar 25, 2025 - 20:21 UTC

Investigating

We are facing some issues with our payment API, we are investigating the root cause and it can affect several payment types and countries.
Posted Mar 25, 2025 - 19:52 UTC