[Nigeria] Verve Cards Transactions – Payment Processing Instability

Incident Report for EBANX

Resolved

Service reestablished.
Posted Nov 26, 2025 - 16:31 UTC

Monitoring

We are monitoring the Verve approval rate and seems to be backing to normal.
Posted Nov 26, 2025 - 14:54 UTC

Investigating

We have identified processing issues affecting VERVE cards in Nigeria. We have already contacted our partners regarding this matter and are waiting for further feedback. We will provide an update as soon as more information becomes available.
Posted Nov 26, 2025 - 14:19 UTC
This incident affected: Nigeria (Cards (credit/debit)).