[Payout][Mexico] SPEI Outage - Arcus

Incident Report for EBANX

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 20:00 UTC

Update

Status:
INVESTIGATING

Window (UTC):
2026-07-06 19:00 → 2026-07-06 20:30


Impact: Incident has been resolved
Posted Jul 06, 2026 - 20:00 UTC

Update

Status:
INVESTIGATING

Window (UTC):
2026-07-06 19:00 → 2026-07-06 20:30


Impact: Incidente has been resolved
Posted Jul 06, 2026 - 19:59 UTC

Investigating

Status:
INVESTIGATING

Window (UTC):
2026-07-06 19:00 → 2026-07-06 20:30


Impact: We have been notified by one of our partners of an unavailability affecting the SPEI payment method. Our partner is actively working to restore full functionality.
Posted Jul 06, 2026 - 19:51 UTC

Identified

Status:
INVESTIGATING

Window (UTC):
2026-07-06 19:00 → 2026-07-06 20:30


Impact: We have been notified by one of our partners of an unavailability affecting the SPEI payment method. Our partner is actively working to restore full functionality.
Posted Jul 06, 2026 - 19:51 UTC
This incident affected: Mexico (SPEI).