Data unavailability on Ebanx Merchant Area (Dashboard) in Crossborder

Incident Report for EBANX

Resolved

The Refunds and Chargebacks pages have been fully restored, and all entities are now available.
Posted Nov 05, 2025 - 21:41 UTC

Monitoring

The Refunds and Chargebacks pages are close to being fully restored, and we are currently monitoring to ensure all entities are completely available. Our team continues to work on implementing a permanent fix to prevent this issue from recurring.
Posted Nov 05, 2025 - 17:49 UTC

Investigating

We are currently experiencing infrastructure issues affecting our databases. As a result, some records in MerchantArea may be missing or temporarily unavailable.
At this time, we have identified Refunds and Chargebacks as impacted entities, though additional entities may also be affected. Our engineering team is actively investigating and working to restore full functionality as soon as possible.
Posted Nov 04, 2025 - 19:18 UTC