[Payout] [Mexico] SPEI Incident

Incident Report for EBANX

Resolved

Payout processing is not being completed by the provider Arcus, an emergency maintenance window has been registered until 3pm UTC.
We received information that Arcus was experiencing some instability, but they have already informed us that everything is fine now. We checked here and the payouts are already being processed correctly.
Posted Apr 10, 2026 - 15:22 UTC

Investigating

Payout processing is not being completed by the provider Arcus, an emergency maintenance window has been registered until 3pm UTC
Posted Apr 10, 2026 - 13:52 UTC
This incident affected: Mexico (SPEI).