[South Africa] Degraded partner performance

Incident Report for EBANX

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 17:04 UTC

Investigating

We are currently experiencing an outage with our Capitec Pay payment partner in South Africa. The issue began at 13:20 UTC and remains ongoing. Our team is actively monitoring the situation and will share updates as they become available.
Posted Oct 31, 2025 - 13:21 UTC