[South Africa][Capitec] Scheduled maintenance

Scheduled for May 17, 01:00 - 04:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted May 15, 2026 - 23:38 UTC

Scheduled

Payment method(s): All Capitec Services
Country: South Africa
Start: 2026-05-17 01:00 UTC
End: 2026-05-17 04:00 UTC
Impact: We would like to inform you about a scheduled maintenance on one of our partners, Capitec. This is an issuer maintenance that will only affect transactions utilizing Capitec services, including Capitec Pay, as well as credit and debit cards issued by them. Despite all EBANX contingency measures, occasional intermittencies or eventual rejections may occur for these specific Capitec payment methods during the window.
Posted May 15, 2026 - 23:37 UTC
This scheduled maintenance affects: South Africa (Capitec Pay).