[Nigeria] Cards Transactions – Payment Processing Instability

Incident Report for EBANX

Resolved

The issue affecting payment processing using some cards on Nigeria has been resolved. We will continue to monitor performance to ensure stability.
Posted Nov 21, 2025 - 11:10 UTC

Update

Our partners are continuing to investigate the root cause of the processing issues affecting some cards in Nigeria. We remain in close contact with their team and will provide further updates once we have significant progress to report.
Posted Nov 20, 2025 - 21:00 UTC

Investigating

We have identified processing issues affecting credit and debit cards in Nigeria. We have already contacted our partners regarding this matter and are waiting for further feedback. We will provide an update as soon as more information becomes available.
Posted Nov 20, 2025 - 17:11 UTC
This incident affected: Nigeria (Cards (credit/debit)).