Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 10, 2026 - 00:30 UTC
Scheduled
Fino payments bank is undergoing maintenance and the following will be affected: - Payment Type: UPI & Cards - Country: India - Start: January 8th, 2:30 PM (UTC) - End: January 12th, 6:30 PM (UTC) - Duration: Approximately 100 hours - Impact: This maintenance involves a partner-side Core Banking System (CBS) migration. During the specified windows, all transaction attempts for Fino Payments Bank will fail or be declined in real-time. No delayed or queued processing is expected for attempts made during this downtime.
Detailed Operational Impact: - UPI Services (Inward, Outward, Mandates) Downtime from January 8th, 2:30 PM (UTC) until January 11th, 4:30 AM (UTC). All UPI acceptance and processing will be unavailable. - Full service unavailability for Fino Payments Bank card-based payments from January 8th, 2:30 PM (UTC) until January 12th, 6:30 PM (UTC). Full service unavailability for card-based payments.
Posted Jan 10, 2026 - 00:18 UTC
This scheduled maintenance affected: India (E-Wallet, Cards (credit/debit)) and Core Platform (Payout API, Payment Page).