Capitec Maintenance

Scheduled for Nov 10, 23:00 UTC  -  Nov 11, 00:00 UTC

Update

We would like to inform you about a scheduled maintenance on CapitecPay. Our technical teams and infrastructure possess a wide range of capabilities and robust protocols to carry out this activity and ensure maximum service stability.

Partner: Capitec
Payment Type: CapitecPay
Country: South Africa
Start: November 10, 2025 – 23:00 UTC
End: November 11, 2025 – 00:00 UTC
Expected Behaviour: Service should remain fully operational during the maintenance.
Posted Nov 10, 2025 - 19:49 UTC

Scheduled

We would like to inform you about a scheduled maintenance on CapitecPay. Our technical teams and infrastructure possess a wide range of capabilities and robust protocols to carry out this activity and ensure maximum service stability.

Partner: Capitec
Payment Type: CapitecPay
Country: South Africa
Start: November 10, 2025 – 23:00 UTC
End: November 11, 2025 – 00:00 UTC
Expected Behaviour: Service should remain fully operational during the maintenance.
Posted Nov 10, 2025 - 19:49 UTC