Service instability when processing Verve card brand transactions in Nigeria

Incident Report for EBANX

Resolved

The service has largely recovered to normal SLA. The main issue ended on 13th September at 07:00 UTC.
Posted Sep 14, 2025 - 00:00 UTC

Update

The issue is still ongoing and we are working together with our partner to reestablish the services.
Posted Sep 12, 2025 - 20:48 UTC

Investigating

Since 16:30 UTC, we have identified an issue when processing transactions with the Verve card brand in Nigeria. All other card brands are functioning normally, and we are monitoring the situation closely.
Posted Sep 12, 2025 - 18:01 UTC