Partner Outage
Incident Report for EBANX
Resolved
Nequi services have returned to normal.
Posted Nov 22, 2024 - 09:11 UTC
Investigating
We have identified an outage with Nequi in Colombia. We are currently in contact with our partner and will provide an update shortly.
Posted Nov 22, 2024 - 07:00 UTC