EBANX Dashboard Maintenance

Scheduled for Mar 24, 19:00 - 19:30 UTC

Update

We will perform scheduled maintenance on the EBANX dashboard for all environments, which may impact performance. The maintenance is expected to last 30 minutes, and a few minutes of intermittence is expected during this period.
Posted Mar 13, 2025 - 19:31 UTC

Scheduled

We will perform scheduled maintenance on the EBANX dashboard for all environments, which may impact performance. The maintenance is expected to last 30 minutes, and a few minutes of intermittence is expected during this period.
Posted Mar 10, 2025 - 14:44 UTC