Payment notifications delay
Incident Report for EBANX
Resolved
The services are re-established.
Posted Jul 23, 2024 - 21:26 UTC
Identified
We are facing issues with our payment notifications.
Posted Jul 23, 2024 - 20:41 UTC