[Egypt] Degraded Partner Fawry Performance

Incident Report for EBANX

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 01:42 UTC

Identified

We are currently experiencing degraded performance with our Fawry partner in Egypt. The issue is still ongoing. Our team is actively monitoring the situation together with the provider to restore normal service as soon as possible. We will continue to provide updates as more information becomes available.
Posted Jan 14, 2026 - 19:32 UTC