PSE payments errors
Incident Report for EBANX
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 14:32 UTC
Identified
We identified some errors with PSE payments, we are in touch with our provider to solve the issue
Posted Jun 17, 2022 - 13:51 UTC
This incident affected: Third party acquirers.