Degraded partner performance
Incident Report for EBANX
Resolved
The intermittency problem has ceased

Date: May 31
Start Time: 00:58 UTC
Posted May 31, 2024 - 01:11 UTC
Identified
We are experiencing intermittency with our partner Klap, which is impacting our cross-border transactions. We are working to resolve the issue and restore our services to normal.

Date: May 30
Start Time: 00:45 UTC
Posted May 31, 2024 - 01:01 UTC