The issue affecting payment processing with our partner has been resolved. We have confirmed that all systems are back to normal and payment processing in Egypt is fully operational. We will continue to monitor performance to ensure stability.
Posted Nov 18, 2025 - 15:49 UTC
Update
We are continuing to work closely with our partner and actively working to restore full service levels as quickly as possible.
Posted Nov 18, 2025 - 13:39 UTC
Update
Our payment partner continues to monitor the situation and is working to resolve the issue as quickly as possible. We remain in contact with their team and will provide further updates as soon as more information becomes available.
Posted Nov 18, 2025 - 12:31 UTC
Identified
We have identified communication issues with one of our payment partners in Egypt, resulting in degraded payment processing. The issue began at approximately 10:50 UTC, and our teams are actively monitoring it.
Posted Nov 18, 2025 - 11:25 UTC
This incident affected: Core Platform (Payments API) and Egypt (Fawry).