Merchant Area – Chargeback Report Unavailable

Incident Report for EBANX

Resolved

The issue affecting the chargeback reports in the Merchant Area has been successfully resolved. All reports are once again available.
Posted Feb 23, 2026 - 14:46 UTC

Investigating

We have identified an issue affecting the chargeback reports in the Merchant Area. As a result, the report is temporarily unavailable while we investigate and implement a fix.

We will provide updates as soon as more information becomes available and once the issue has been resolved.
Posted Feb 20, 2026 - 18:03 UTC