[South Africa] Degraded partner performance

Incident Report for EBANX

Resolved

The incident is now resolved.
Posted Nov 05, 2025 - 10:23 UTC

Investigating

We are currently experiencing an outage with our Capitec Pay payment partner in South Africa. The issue began at 08:07 UTC and remains ongoing. Our team is actively monitoring the situation and will share updates as they become available.
Posted Nov 05, 2025 - 09:26 UTC